Featured image of post [模板]割点

[模板]割点

【模板】割点(割顶)

题目背景

割点

题目描述

给出一个 $n$ 个点,$m$ 条边的无向图,求图的割点。

输入格式

第一行输入两个正整数 $n,m$。

下面 $m$ 行每行输入两个正整数 $x,y$ 表示 $x$ 到 $y$ 有一条边。

输出格式

第一行输出割点个数。

第二行按照节点编号从小到大输出节点,用空格隔开。

样例 #1

样例输入 #1

1
2
3
4
5
6
7
8
6 7
1 2
1 3
1 4
2 5
3 5
4 5
5 6

样例输出 #1

1
2
1 
5

提示

对于全部数据,$1\leq n \le 2\times 10^4$,$1\leq m \le 1 \times 10^5$。

点的编号均大于 $0$ 小于等于 $n$。

tarjan图不一定联通。

Code

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef double db;
typedef pair<int, int> pii;
typedef pair<long long, long long> pll;
typedef vector<int> vi;
typedef vector<long long> vll;
typedef vector<pii> vpii;
typedef vector<pll> vpll;

const int N = 100010, MOD = 1e9 + 7, INF = 0x3f3f3f3f;
int n, m, u, v, dfn[N], ti, fa[N], low[N], child[N], cnt;
bool ge[N];
vi g[N];

void tarjan(int u) {
    low[u] = dfn[u] = ++ti;
    for (auto v : g[u]) {
        if (!dfn[v]) {
            fa[v] = u;
            child[u]++;
            tarjan(v);
            low[u] = min(low[u], low[v]);
            if (fa[u] && low[v] >= dfn[u] && !ge[u]) ge[u] = true, cnt++;
        } else if (v != fa[u]) {
            low[u] = min(low[u], dfn[v]);
        }
    }
    if (fa[u] == 0 && child[u] >= 2 && !ge[u]) {
        ge[u] = true;
        cnt++;
    }
}

int main() {
#ifndef ONLINE_JUDGE
    freopen("data/in.txt", "r", stdin);
    freopen("data/out.txt", "w", stdout);
#endif
    ios::sync_with_stdio(false);
    cin >> n >> m;
    for (int i = 1; i <= m; i++) {
        cin >> u >> v;
        g[u].push_back(v);
        g[v].push_back(u);
    }
    for (int i = 1; i <= n; i++)
        if (!dfn[i]) tarjan(i);
    cout << cnt << "\n";
    for (int i = 1; i <= n; i++)
        if (ge[i]) cout << i << " ";
    return 0;
}
Licensed under CC BY-NC-SA 4.0
本站已安全运行
总访问量 次 | 访客 人 | 共 27 篇文章
Built with Hugo
主题 StackJimmy 设计